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Portrait is a texture-mapping software designed to realize catalogues and present fashion collections or room 
decorations without any need to produce before the respective films, cylinders or weave the fabric. Portrait 
allows you to dress any object of your choice with any design you like. The work with Portrait starts and is 
based on the digital image. In order to achieve realistic results the software retains the lighting and 
shadowing effects of the original image and takes account of the perspective and surface structure of the 
respective objects (e.g. pleats, creases, distortion).  
Portrait is an excellent marketing tool for apparel, fashion and home-textile. Presentations of the same dress 
in different colors and/or designs or of room decorations in different styles become easy and cost effective. 
PORTRAIT 2 is DGS’ newest release with a more flexible and simple user interface. You can define in an 
efficient way the areas to be texture-mapped, the fabric movement and the mapping itself.  
 
This manual refers to version 3.x of Portrait 2. 
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With About Portrait 2 from the Help menu you can control the installed software version. 
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DGS - as the exclusive holder of the property rights on the software - grants licenses or sub-licenses for the 
usage of the software. A software activation key protects these licenses. The software key permits the user 
to activate the purchased modules. The license type or the activated modules can be controlled inside the 
License manager in the Help menu. 
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As a licensee you are not entitled to reproduce, copy, sell or cede the software license without DGS’ prior 
written authorization. You are also not entitled to duplicate the user manual. 
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DGS warrants that the software conforms to the published specifications in effect on the date of delivery. 
DGS points out, that the software may not satisfy all application fields and that the use of the software may 
not be uninterrupted or error-free. Above all, DGS does not warrant that the software meets customer 
specific requirements. The customer only is responsible for installation, usage and intended results of the 
software.  
DGS continues to develop the software, but does not warrant for modified versions in the sense of the above 
paragraph, unless it will not be proved, that existing errors are due to done modifications. 
DGS shall under no circumstances be liable to the customer or third parties for any direct, indirect, special, 
punitive or incidental damage arising from the usage or non-usage of the software, including lost profits, lost 
savings, increased costs, goodwill or stoppage of other work. DGS shall be exclusively liable for the 
functionality of the software. DGS shall not be liable for direct or indirect damages, which arise from DGS’ 
intervention or non-intervention at the installation site. 
DGS also shall not be liable for the partial or total loss of data. DGS recommends to make every day data 
backups and in particular before DGS’ intervention at the installation site. 
DGS shall not be liable for damages arising from corrections, customizations or other modifications of the 
software done by third parties not authorized by DGS. 
The customer is responsible for the environment, its security and the observance of the norms in vigor. 
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Windows 2000/XP are the suggested OS. It is possible to use the software also with Windows 95/98/NT. 
To have good performance it’s important to work with a resolution not hgher than 1280x1024 pixels with 32 
bit color depth. 
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This software product is protected with a software code and an hardware key (dongle).  Without these 
protections is possible to test many software functionality but it will not be possible to save the projects and 
to print the imges generated. Along will be a written over the preview window. 
 
The license check is automatic: when the program starts if you do not have the right protections, it will 
appear the “License manager” window where you will be able to set the dongle and the license. 
 

 
 

 
The Systems ID is the univocal code of the dongle. It is necessary to obtain the license code contacting 
DGS. 
The label “License manager server location” indicates where is the dongle in the local are network (LAN). If it 
is connected to the local coputer you will find the written “Local machine” viceversa you will find the IP 
address of the computer where the dongle has been connected. 
At the first start, the program will check the hardware key on the local computer. To change the search 
setting push on the “Change” button and write the right IP address. 
In the list you will see all the license registered in the dongle. Actually each hardware key can contain more 
software licences. 
To insert a new license you have to write a code, that DGS will give you, in “License” text box. 
 

In the status bar of the program there is 
an icon like a semaphore. It will be 
green if there is a valid license, yellow 
when the software is looking for the 
license, red when the software is not 
activated. In the last case it is possible 
to use the program like a demo. 
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The user interface of Portrait 2 is divided in the main menu with the main window shown in the figure below 
and the relative toolbar. 
 

 
 
Portrait 2 manages two types of documents: images (in various formats) and the so-called files portrait. 
Images are original e.g. scanned images (hereinafter called original images) and mapped images 
(hereinafter called modified images). The files portrait are the core of the software, as they contain all the 
information necessary to determine which pattern shall be mapped onto which object in which way. Thus, a 
file portrait contains the link to the original image and the link to the pattern. It is recognizable by its file 
format *.aio. 
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This paragraph describes briefly the commands of the main menu and the toolbar. 
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The commands of the main menu are indicated in the following way:    “MainMenuItem->SubMenu” 
 
MainMenuItem refers thereby to one of the items in the main menu, while SubMenu refers to the commands 
that appear when selecting the menu itself. 
 
File->New -   deletes the current objects and control vectors in order to 

apply new modifications to the loaded image 
File->Open file portrait - CTRL+O -  loads a file portrait 
File->Save - CTRL+S -  saves the current modifications as file. 
File->Save file portrait As … saves the current modifications as file under a new name 
File->Open Image … -  loads an image to be modified 
File->Save Image … saves a modified image 
File->Print … - CTRL+P -  prints a modified image 
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File->Print preview -  shows the print preview of the modified image. 
File->Exit closes PORTRAIT 2 
 
Image->Rotate … rotates the image 
Image->Resize … resizes either the image as the gridlines 
Image->Crop … re-cuts / crops the image 
Image->Color balance … changes the gamma, contrast and brightness of the loaded 

image 
Image->Define meter applies the real / true-to-scale dimensions to the selected 

image content. 
Image->Reset meter cancels the setting of the real / true-to-scale dimension for the 

selected image content. 
Image->Activate masked area  Enable/disable the masked areas 
 
 
Objects->Select -  Selects an object. 
Objects->Add new -  Adds a new object. 
Objects->Masked area  Defines areas inside an object, which shall remain un-mapped 
Objects->Share bound Makes two objects share a part of the bound in common. 
Objects->Create grid->Trace…   Generates the control vectors, which define the movement of 

the pattern to texture-map. 
Objects->Properties -  Characterizes the modifications to apply to the object. 
Objects->Apply -   Applies the pattern to texture-map to one or more objects.  
Objects->Unmap current object -  Un-maps the selected object. 
Objects->Smooth bound Smoothes the bound of the selected object. 
Objects->Modify… The different options are listed in paragraph 3.9 
 
View->Show/Hide bound  - F1  Shows / hides the bounds of the objects 
View->Show/Hide vectors - F2  Shows / hides the control vectors just of the objects 
View->Show/Hide masked area - F3  Shows / hides the masked areas 
View->Show/Hide grid - F4  Shows / hides the grid 
View-> Show/Hide meters Shows / hide the meter for each group 
View->Zoom all - F8 Shows the entire image 
View->Zoom out - F9 zoom - 
View->Zoom in - F10 zoom + 
View->Toolbar Shows / hides the toolbar 
View->Options… Defines the color to assign to the control vectors 
View->Properties… Informs about the current modifications 
 
Help->About Portrait II displays information regarding Portrait 2. 
Help->License manager visualizes the activated software modules. 
Help->Manual The present manual is separately supplied from the software 

and it can be downloaded from our web site www.dgs-net.it in 
downloads section. 
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Selecting Properties from the View menu informs you about the modifications carried out on the loaded 
image. In particular the statistics contain the name and the path of the original image, its dimensions (in 
pixel and millimeters), the name of the created objects, the name of the group to which they belong, the 
respective pattern to texture-map, the used memory and the total memory available. 
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With Options from the View menu you can choose the application colors. In particular you can decide the 
color to assign to the bounds, gridlines and control vectors. You can also decide on the color, which will 
appear in the moment you select a bound or a vector. Click on the colored fields inside the Options window 
and select the desired color from the displayed color palette. 
It is also possible to set the default directories where the software can find the files to use: images, patterns 
and *.aio files. 
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This chapter describes the standard procedure to follow in order to map patterns onto an original image:  

1) load an image. 

2) enter the real dimension of the image components with define meter in order to assure a true-scale 

mapping of the pattern. 

3) draw a bound around the objects you want to texture-map or redress. 

4) trace the control vectors to define the movement of the pattern onto the object. 

5) control the movement of the pattern by visualizing the respective mapping gridline. 

6) set the mapping parameters. 

7) apply the pattern to the object. 

8) save the settings described in point 2) to 7) as file portrait (file format .aio). 

9) save and print the modified or mapped image. 

During this procedure it is always possible to create, delete, group or regroup objects, modify the mapping 
parameters and apply new patterns. 
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With Open Image from the File menu or by pressing on the  button you can search in the various 
directories for a specific image to load. The choice of the file format (e.g. tiff) and the file name can serve 
thereby as selection criteria. You get of every selected image a preview and other image specific information 
such as resolution, dimensions, size in terms of space occupied on the hard disk and unit of measurement. 

 
 
The supported format image are: 
 
• JPG (high compressed 

raster image with low 
resolution); 

• TIFF (compressed raster 
image with high resolution); 

• XPF (high compressed 
image with high resolution 
and step information, 
Ramsete III format); 

• PSD (Photoshop images, 
also multichanel); 

• SCN (Btree images). 
 
 
The “File type” setting works like 
a filter. So in the list will appear 
only the right files. 
You can also chose the “All 
supported files” to see all the 
images present in the folder that 
the program can loads. 



 

 8

���� �
������
������
�
���
�

With Define Meter from the Image menu you may enter the real dimension of the image components. The 
software compares the entered value to the real dimensions of the pattern and calculates automatically the 
respective scale factor in order to assure the true-scale mapping of the pattern. 
 

 
 
Trace the desired image component with the mouse or pen and define its dimension in millimeters.  
It is possible to set the meter just defined also for single groups of objects. The remaining object will be 
mapped according to the single setting. Selecting “All” in the Groups label the same meter will be set for 
everything. After having confirmed the entered value you will find the chosen scale for reference above the 
main window. 
 

 
 
With Reset meter  from the Image menu you can cancel or undo the set dimension. 
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The software recognizes only those areas of the image as areas to be texture-mapped, which are identified 
by a drawn bound as objects. In order to draw a bound select Add new from the Objects menu or press the 

 button. The cursor becomes a cross. Trace the bound using the left mouse key, the “Enter” key on the 
keyboard or the pen. Every click corresponds to a single point. If you want to draw smooth bounds then keep 
the left button of the mouse pressed or the key of the pen while drawing the bound.  
 

 
 
To finish the drawing, press the right mouse key or the pen key. In order to facilitate the tracing of the 
bounds use the “End” key to center the image view on the position of the cursor. 
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The function Share bound from the Object menu or the pressure of the “Space” key on the keyboard allows 
you to make two areas share the same bound. This function is indispensable for an accurate tracing of the 
bounds and thus avoids that some parts of the image remain unmapped. Select the given bound (press on 
the  button) and identify the part to share by clicking on its first and last point (these points become green). 
 

 
 
Confirm this selection by clicking again on the shared bound, now you can continue to draw the new bound. 
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On the basis of the control vectors the software builds up the gridline, which determines the way the pattern 
will be mapped onto the object. The more accurately the control vectors follow the shape of the object (e.g. 
creases, pleats) the better and more realistic become the mapping result. Control vectors must be drawn for 
every bound by the  or  button or with Trace horizontal vectors or Trace vertical vectors from the 
menu Object->Create grid. 
 

 
 
The vectors are generated in the same way as the bounds (see chapter 3.3). A minimum of two vertical and 
two horizontal vectors is required. Draw the vectors outside the bound and make sure that they cross each 
other in the correct way (see fourth figure below). 
 

 
 

1) Wrong: insufficient number of vectors 
2) Wrong: one vector overlaps the bound. 
3) Wrong: the vectors do not cross each other. 
4) Correct. 

 
In order to avoid undesired distortions of the mapped pattern keep the 
distance between the intersection points of the vertical vectors and also the 
distance between the horizontal vectors more or less constant. 
(AB ~= CD and AC ~= BD). 
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Visualizing the gridline helps you to control whether it follows correctly the shape of the object. Select Create 
grid from the menu Objects->Generate Grid or click on the  button. If the gridline seems to be deformed 
or distorted make sure that the distance between the intersection points of the vertical vectors and the one 
between the horizontal vectors is kept constantly (See figure 3.4). 
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For every object (created bound) you can define parameters, which characterize 
the mapping. Select therefore Properties from the Objects menu or click on the 

 button: 
����� the object name must be univocal. 
���	
� a group refers to a range of objects, which shall be texture-mapped at the 
same time.�
������
��������� in this section you will see the pattern or the color connected to 
the object. Clicking with the left button of the mouse on the box it possible to 
change it. If you load an XPf image (Ramsete format) like a pattern, you will be 
able to use all the colorways registered in the image. Clicking with the right button 
of the mouse it will appear the colorways list.  
��

�
������� you can choose between the following mapping modes: 

�����: maps a pattern onto the object and retains thereby the lightness 
of the original image. 
�������	�
	����: serves to reduce or increase the lightness of the 
mapping result. The lighter the chosen reference the darker becomes the 

mapping result and vice versa.  
�����: maps one color onto the object and retains thereby the lightness 

of the original image.  
��
�: maps a pattern without taking account of the light and dark 
shadings of the original image. The result is a pure two-dimensional 
object. 
�����: with this command is possible to change the lightness of the 
pattern. Moving the indicator to right means more light, moving to left 

means more dark.  
 
�������
� enter the rotation or mirroring degree of the pattern. 
�����
���� enter the scaling factor (in percentage) of the pattern to apply to the real dimension of the object. 
����
�����
�
����� activates the defined setting of the pivot on the pattern (see paragraph 3.7). 
����������
����� activates the defined pivot to position the pattern on the object (see paragraph 3.7). 
������
����� erase the pivot associated with the pattern. 
������ enables the meter associated with the pattern. 
�

��� applies the pattern or color to the object (see paragraph 3.8). 
�
���
� un-maps the object (see paragraph 3.8). 
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The pivot serves to position and map the pattern in a precise way on the object. This can be useful in case 
that you want to center the pattern on the object or you want to apply the same pattern in a continuous way 
over several objects.  
 
First identify with the mouse or pen a pivot as reference point inside the pattern. Click on “Pivot pattern” and 
choose the reference point inside the Pattern window (see figure) with a single click. 
Additionally, you can also define a color, which shall be considered as transparent during texture-mapping. 
Therefore, activate the field color mask and then click on the button “Set transparency”. 
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Now define where to position the reference point of the pattern on the object. Therefore, identify with “Pivot 
image” the according reference point on the object. Attention: the pivot must be located inside the bounds of 
the selected object. 
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In general there are three ways to apply the pattern to the objects. 
 
Application to the current object: applies the pattern to a single object; select Current from the Apply menu 
(submenu of Objects), click on the  button or press on “Apply current” in the object properties window. 
 
Application per groups: select Group from the Apply  menu (submenu of Objects) or click on the  button. 
With this function is possible to modify the settings of all the objects  of the selected group. These are the 
possible operations: 

• Load a new pattern with the “Select pattern” button; 
• Choose the colorways in the combo box; 
• Choose the color with the “Select color” button; 
• Change the reference color with the “Assign reference color” button; 
• Apply the smooth with the “Force objects smooth” check button; 
• Select the mapping mode in the “Group mapping mode” section; 
• Set a scale factor (percetuage). The 0 value means the each object will be scaled according to its 

own setting. The maximum value is 500; 
• Enable the meter setting; 

 

 
 

 
 
Total application:  applies the pattern to the entire image. Select All from the Apply menu (submenu of 

Objects). 
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In order to undo the mapping select the object bound and Un-map current object from the Objects menu, 
click on the  button or click on “Un-map object” inside the object properties window. 
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The function Smooth bound from the Objects  menu integrates the mapped object more smoothly and more 
continuously into the background image, as it reduces the contrast between bound and background colors. 
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You can modify bounds and control vectors of an already defined object with the following commands: 

 selects the desired control vector, which can be moved with the cursor. 

 deletes the selected control vector; in case of bounds this function deletes additionally to the bounds 
also the related vectors. 

 inserts a point. 

 deletes a point. 

 moves a point. 

 duplicate a vector 
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In order to undo the last modification carried out press the keys “CTRL+Z” at the same time (see also Exhibit 
A “Shortcuts). 
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The commands Rotate, Resize, Crop and Color balance from the Image menu’ modify the original or 
background image as well as the created objects. You can save the carried modifications under the same file 
or a new one. 
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Rotate rotates the whole image according to a chosen degree. Positive degrees result in clockwise rotations 
while negative degrees in anti-clockwise rotations. 
 
Resize  re-dimensions the whole image according to a scaling factor (percentage). As default the software 
retains the original proportions during scaling. But you can also enter different scaling factors for the x and y 
axis after having deactivated the field “Maintain aspect ratio”. 
 
Crop cuts the selected area including its bounds. 
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With  Color balance you can do same last color corrections by setting the gamma, contrast and lightness of 
the original or background image. 
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A Masked area is an area, which should not be mapped (e.g. the button of a jacket). To create this object 
press the  button, draw the according bound around the area. During the creation of a Masked are” the 
bound are hidden. 
To activate the Masked area it’s necessary to chose the “Image->Activate masked area” command or push 
the  button on the toolbar. Otherwise the Masked area will be ignored. 
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Save file portrait As from the File menu allows you to save the modifications to apply to the respective 
original image as file indicating thereby file name and the directory where to save the file. 
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Selecting Save image from the File menu allows you to save the modified or mapped image indicating the 
file name and the directory. 
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Print setup from the File menu allows you to define the printing parameters. You can decide on the print 
layout, enter a comment and decide whether date, time and file name shall also appear on the print out. 
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With Print preview form the File menu or by clicking on the  button you get a print preview of the image. 
To print the image press Print from the File menu, click on the  button or press at the keys “CTRL+P” at 
the same time (see also Exhibit A “Shortcuts). 
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If you want to apply to another image the modifications defined in one of the previously saved file portrait, 
then select Open file portrait from the File menu or press the  button. The software loads automatically 
also the related image and displays the defined bounds and vectors, which can be modified according to the 
descriptions in the previous paragraphs. 
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EXHIBIT A - SHORTCUTS 
 
Keys combination Description 
F1 Enables/disables visualization of all bounds. 
F2 Enables/disables visualization of a single bound with its vectors. 
F3 Enables/disables visualization of the Masked areas. 
F4 Enables/disables visualization of the grid of the selected object.. 
F8 Visualizes the entire image centered on the screen. 
F9 Zooms out  (-). 
F10 Zooms in  (+). 
ENTER Inserts a new point when you create bounds or vectors. 
SPACEBAR Enables/disables the point sharing during bound creation. 
END Centers the image visualization. 
BACKSPACE Deletes the last insert point. 
CTRL+Z Undoes the last modification carried out and restores the object in the 

way it has been before. 
CTRL+O Opens a Portrait 2 document  
CTRL+S Saves quickly the Portrait 2 document 
CTRL+P Activates printing 
Arrows To move the background image 

 
 
EXHIBIT B – PATH 
 
�� The program Portrait.exe will be installed in the standard directory c:\program files\dgs\portrait 

�� Given a file portrait the software searches for an image associated with this file first in the memorized 

link/path, then in the *.aio file directory. 

�� The software searches for the patterns first in the memorized links/paths and then in the subdirectory 

“PATTERN” of the *.aio file. 

 


